Freitag, 11. Juni 2010

VMWare vConverter 4.0.1 Fehlermeldung “Visual C++ Runtime Error … 1920″

Ich beschäftige mich gerade mit einem neuen Projekt, der Umwandlung vonphysikalischen Servern in virtuelle Server. Dieses ist für uns ein sehr wichtiger Vorgang, denn wir haben diverse Altsysteme, die zukünftig als virtuelle Server laufen sollen, damit wir die alte Hardware endlich entsorgen können.

Deswegen habe ich mich entschlossen, den VMware vCenter Converter 4.0.1 von VMware zu testen. Dieses Programm soll in der Lage sein, diesen Vorgang selbstständig zu erledigen. Testweise habe ich es mit einem neu aufgesetzten englisch sprachigen Windows 2000 Server getestet. Das Programm ließ sich einwandfrei auf dem Server installieren und innerhalb von 1-2 Stunden hatte er eine virtuelle Maschine erstellt. Darüber werde ich später noch berichten, dass ist heute nicht Inhalt dieses Beitrages.

Ich habe heute versucht den VMware vCenter Converter 4.0.1 direkt auf einer Produktivmaschine zu installieren. Dieses ist, wie man schon vermutet, natürlich fehlgeschlagen. Und zwar mit folgenden Meldungen:

Am Ende der Installation, als das Installationsprogramm die neu installierten Dienste auf dem Server starten wollte, erscheint folgende Meldung:

Visual C++ Runtime Library
Programm: …\VMware…\vmware-converter.exe
This application has requested the Runtime to terminate it in an anusual way.

Im Ereignisprotokoll wurde folgendes angezeigt:
Quelle: MsiInstaller
Ereignis-ID: 11920
Product: VMware vCenter Converter Standalone — Error 1920
Service VMware vCenter Converter Server (vmware-converter-server) failed to start. Verify that you have sufficient privileges to start system services.

Mir war zunächst völlig unklar warum die Meldung erscheint. Nach stundenlanger Suche in diversen Internet Foren bin ich dann auf eine vermeintliche Lösung gestoßen:

Die Englische Programmversion des VMware vConverter 4.0.1 (es gibt nur eine englische Version) hat anscheinend Probleme mit Deutschen Windows Server Versionen. Am Ende des Installationsvorganges sucht das Programm im Active Directory des Servers nach derSicherheitsgruppe “Domain Admins, welche auf einem Deutschen Server selbstverständlich nicht vorhanden ist. Legt man diese Gruppe aber manuell im AD an und nimmt die Administratoren darin auf, so wird die Fehlermeldung bei der Installation nicht mehr angezeigt.


Keine Kommentare:

Kommentar veröffentlichen

Dieses Blog durchsuchen